Notifications
Clear all

Armbian: Access the Remote Desktop of Orange Pi with VNC


christophe
Posts: 251
Admin
Topic starter
(@chris)
Member
Joined: 4 years ago
wpf-cross-image

Orange Pi (and Raspberry Pi) are mini PCs boards that are very often used remotely without screen (neither keyboard nor mouse). In some cases, or if you start on Linux, you would like with a graphical access to the Linux desktop. In this tutorial we will learn how to install and configure a Virtual Network…

2 Replies
c8b1ca7b0f18aac81a57037c4d2f93c0?s=80&d=mm&r=g
Posts: 1
 DeeJayOne
Guest
(@DeeJayOne)
Joined: 2 years ago

First, thanks for this post !

I have some trouble while trying to setup an autostart with tightvncserver :
Chapter "Create a systemd service to start VNC automatically at startup"
I have just changed the user name and the depth (24 in my case) parameter in the files.
The service start well after a boot, the status tells that all seems OK but when I try to connect with the client (tightvnc) I have the following message :
Unable to contact settings server
/usr/bin/dbus-launch terminated abnormally without any error messages.
Then, a second error message :
Unable to load a failsafe session
Unable to determine failsafe sessio name. Possible causes xfconfd isn't running (D-Bus setup problem); environment variable $XDG_CONFIG_DIRS is set incorrectly (must include "/etc"), or xfce4-session is installed incorrectly.
Before creating the service (when I started manually tightvncserver), all worked fine.
I have compare the 2 proccesus (manual launching and systemd autostart and there well the same) with the "ps -o pid,user,%mem,command ax | sort -b -k3 -r" cmd :
706 pizero 1.3 Xtightvnc :1 -desktop X -auth /home/pizero/.Xauthority -geometry 1024x768 -depth 24 -rfbwait 120000 -rfbauth /home/pizero/.vnc/passwd -rfbport 5901 -fp /usr/share/fonts/X11/misc/,/usr/share/fonts/X11/Type1/,/usr/share/fonts/X11/75dpi/,/usr/share/fonts/X11/100dpi/ -co /etc/X11/rgb

If I stop the systemd service and restart tightvncserver manually, it works well again.
Would you have any idea ?

Reply
b05f9bea02382c2d0b74f2abe99ae784?s=80&d=mm&r=g
Posts: 1
 Maxx Eastick
Guest
(@Maxx Eastick)
Joined: 1 year ago

Also, seem's you need to add xfonts-base to get vncserver running (sudo apt install xfonts-base)

Reply
Share:
Join Us!
Recent Posts
Last Articles
DIY Projects
DIY Projects